[U-Boot-Users] soft_i2c

Wolfgang Denk wd at denx.de
Fri Apr 23 16:07:28 CEST 2004


In message <20040423153814.B8298 at gateway.bln.innominate.local> you wrote:
> 
> a small patch for soft I2C to make it more readable
> and more general - should not break anything.
...

> @@ -30,9 +30,17 @@
>  #include <ioports.h>
>  #endif
>  #include <i2c.h>
> +#include <asm/hardware.h>

Why do you include <asm/hardware.h>? It was not necessary so far, so why should we add it?

>  #if defined(CONFIG_SOFT_I2C)
>  
> +#ifdef	CONFIG_MPC8260
> +  #define DECLARE_I2C_PORT volatile ioport_t *iop = ioport_addr((immap_t *)CFG_IMMR, I2C_PORT);
> +#endif
> +#ifdef	CONFIG_8xx
> +  #define DECLARE_I2C_PORT volatile immap_t *immr = (immap_t *)CFG_IMMR;
> +#endif
> +
>  /* #define	DEBUG_I2C	*/
>  
>  
> @@ -75,12 +83,8 @@
>   */
>  static void send_reset(void)
>  {
> -#ifdef	CONFIG_MPC8260
> -	volatile ioport_t *iop = ioport_addr((immap_t *)CFG_IMMR, I2C_PORT);
> -#endif
> -#ifdef	CONFIG_8xx
> -	volatile immap_t *immr = (immap_t *)CFG_IMMR;
> -#endif
> +	DECLARE_I2C_PORT
> +		

Do you really think this is more readable and more general?

To me this is not worth the change.

Best regards,

Wolfgang Denk

-- 
Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at denx.de
Beware of the Turing Tar-pit in  which  everything  is  possible  but
nothing of interest is easy.




More information about the U-Boot mailing list