[U-Boot-Users] [GIT PULL] [ARM] Please pull from git://denx.de/git/u-boot-arm.git

Peter Pearse peter.pearse at arm.com
Tue Sep 11 17:31:05 CEST 2007


Wolfgang
 
	Please pull from git://denx.de/git/u-boot-arm.git

	The changes address your comments:-

> The following issues need to be addressed:
> include/led.h => seems specific to the at91rm9200dk board only,
>                  please move to board directory. Also, the calls to
>                  these functions should be handled without #ifdef's
>                  in common code. Either use existing functions hooks,
>                  or weak references.

Moved to asm-arm as coloured_led.h 
- I want to play with the coloured leds on other ARM boards sometime.

> drivers/at45.c => has coding style issues - indentation of long,
>                   wrapped around lines is broken.

- ran Lindent on it

> cpu/arm920t/start.S => I'm surprised to see a lot of intialization
>                 code has now been added to the "reset" entry point.
>                 Is this by accident, or am I missing something?

Ulf and I missed that CONFIG_BOOTBINFUNC has been deprecated and split into 
	CONFIG_SKIP_RELOCATE_UBOOT
	CONFIG_SKIP_LOWLEVEL_INIT
as described in the README.

Since the CONFIG_BOOTBINFUNC code has not been tested e.g. there was no 
lowlevelinit(), I have removed it for now.

I want to take this opportunity to remind ARM developers that any
intialization 
- of the cpu   should take place in   cpu/<armcpu>  /<file>::cpu_init_crit()
- of the board should take place in
board/<armboard>/<file>::lowlevel_init().

There are currently various misplaced initializations which I hope to sort
out 
with the board maintainers.

Anyone submitting at91rm9200 code should be aware that currently 
- the define CONFIG_AT91RM9200 is used by
	at91rm9200dk
	cmc_pu2
	mp2usb      
- the define CONFIG_AT91RM9200DK is used by 
	at91rm9200dk
	mp2usb      
please make sure not to break the other boards.

> include/config_cmd_all.h: "CONFIG_CMD_MUX" is a pretty generic name,
>                 while here it is used for a board or CPU specific
>                 feature only. I suggest you rename this into
>                 something which has a "AT91" in the name, like
>                 "CONFIG_CMD_AT91_SPIMUX" or so.

- done

  Signed-off-by:	Peter Pearse <peter.pearse at arm.com>
  Signed-off-by:	Ulf Samuelsson <ulf at atmel.com>

---
The following changes since commit 38ad82da0c1180ecdeb212a8f4245e945bcc546e:
  Grzegorz Bernacki (1):
        [GP3SSA] Add define CONFIG_MPC85XX_PCI2 in config file to allow
u-boot to

are found in the git repository at:

  git://www.denx.de/git/u-boot-arm.git

Peter Pearse (10):
      Rename CONFIG_CMD_MUX to CONFIG_CMD_AT91_SPIMUX
      Ran Lindent on drivers/at45.c
      Move include/led.h to board/at91rm9200dk
      Add coloured led interface for ARM boards.
      Changed API name to coloured_led.h
      Merge with git://www.denx.de/git/u-boot.git
      Merge with git://www.denx.de/git/u-boot.git
      Merge with git://www.denx.de/git/u-boot.git
      Merge with git://www.denx.de/git/u-boot.git
      Final tidy

 board/at91rm9200dk/led.c                  |    2 +-
 cpu/arm920t/start.S                       |  128 ++---------
 drivers/at45.c                            |  334
++++++++++++++---------------
 include/{led.h => asm-arm/coloured_led.h} |    2 +-
 include/config_cmd_all.h                  |    2 +-
 lib_arm/board.c                           |   24 ++
 6 files changed, 210 insertions(+), 282 deletions(-)
 rename include/{led.h => asm-arm/coloured_led.h} (97%)
---







More information about the U-Boot mailing list