[U-Boot] [PATCH 4/9 v3] 83xx, i2c: add mux support for fsl_i2c

Kim Phillips kim.phillips at freescale.com
Wed Feb 25 01:08:59 CET 2009


On Tue, 24 Feb 2009 08:53:33 +0100
Heiko Schocher <hs at denx.de> wrote:

> Hello Kim,
> 
> Kim Phillips wrote:
> > On Thu, 19 Feb 2009 17:24:09 +0100
> > Heiko Schocher <hs at denx.de> wrote:
> [...]
> >>  unsigned int i2c_get_bus_num(void)
> >>  {
> >> +#if defined(CONFIG_I2C_MUX)
> >> +	return i2c_bus_num_mux;
> >> +#else
> >>  	return i2c_bus_num;
> >> +#endif
> >>  }
> > 
> > I don't get this mux variant - why aren't we reusing i2c_bus_num in the
> > mux case?
> 
> Because i2c_bus_num is used as an index which hardware i2c controller
> is used (0 or 1). In CONFIG_I2C_MUX case, you have more than 2 i2c
> busses -> i2c_bus_num would be greater than 1, so you must have a
> variable, where you store which hardware adapter you use, and one
> which stores on which i2c bus you are.

so instead of naming it "i2c_bus_num_mux" it should be renamed
"i2c_adapter_num"?, or does i2c_get_bus_num() still imply that it will
return the /bus/ number?  Perhaps we should we have a separate function
altogether?

Kim


More information about the U-Boot mailing list