[U-Boot] [PATCH V2] MPC8xxx: Define cache ops for USB

Vikram Narayanan vikram186 at gmail.com
Fri May 25 16:29:15 CEST 2012


Hello Marek,

On 5/25/2012 7:44 PM, Marek Vasut wrote:
> This patch conditionally defines flush_dcache_range() and
> invalidate_dcache_range() on MPC8xxx, to avoid EHCI complaining,
> resulting in the following output:
<snip>
> +
> +void invalidate_dcache_range(unsigned long start, unsigned long stop)
> +{
> +}
> +
> +void flush_dcache_range(unsigned long start, unsigned long stop)
> +{
> +}

Don't mind if this is a stupid question.
Can't this be placed in some common header?
Just to avoid code duplication!

Thanks,
Vikram


More information about the U-Boot mailing list