[U-Boot] [PATCH 1/2] spi: cf_qspi: Use DIV_ROUND_UP at appropriate place

Jagan Teki jagannadh.teki at gmail.com
Fri Jun 14 17:10:15 CEST 2013


On 14-06-2013 18:45, Richard Retanubun wrote:
> On 14/06/13 09:12 AM, Axel Lin wrote:
>> This change slightly improves readability.
>>
>> Signed-off-by: Axel Lin<axel.lin at ingics.com>
>> ---
>>   drivers/spi/cf_qspi.c | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/spi/cf_qspi.c b/drivers/spi/cf_qspi.c
>> index a37ac4e..06bcf91 100644
>> --- a/drivers/spi/cf_qspi.c
>> +++ b/drivers/spi/cf_qspi.c
>> @@ -171,7 +171,7 @@ int spi_xfer(struct spi_slave *slave, unsigned int
>> bitlen, const void *dout,
>>       volatile qspi_t *qspi = dev->regs;
>>       u8 *txbuf = (u8 *)dout;
>>       u8 *rxbuf = (u8 *)din;
>> -    u32 count = ((bitlen / 8) + (bitlen % 8 ? 1 : 0));
>> +    u32 count = DIV_ROUND_UP(bitlen, 8);
>>       u32 n, i = 0;
>>
>>       /* Sanitize arguments */
> ACK. Thanks for the cleanup.
>
> Signed-off-by: Richard Retanubun<richardretanubun at ruggedcom.com>

Reviewed-by: Jagannadha Sutradharudu Teki <jagannadh.teki at gmail.com>

--
Thanks,
Jagan.


More information about the U-Boot mailing list