[U-Boot] [PATCH v2 3/4] sunxi: emac: Rename DMA_CPU_TRRESHOLD to EMAC_RX_BUFSIZE

Hans de Goede hdegoede at redhat.com
Sat Apr 25 13:51:47 CEST 2015


Besides being spelled wron, the DMA_CPU_TRRESHOLD define actually has
nothing to do with DMA as we only use mmio fifo access. Rename it to
EMAC_RX_BUFSIZE to properly reflect what it does.

Signed-off-by: Hans de Goede <hdegoede at redhat.com>
---
 drivers/net/sunxi_emac.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/net/sunxi_emac.c b/drivers/net/sunxi_emac.c
index 038f474..e43b1e7 100644
--- a/drivers/net/sunxi_emac.c
+++ b/drivers/net/sunxi_emac.c
@@ -153,7 +153,7 @@ struct sunxi_sramc_regs {
 #define EMAC_CRCERR		(0x1 << 4)
 #define EMAC_LENERR		(0x3 << 5)
 
-#define DMA_CPU_TRRESHOLD	2000
+#define EMAC_RX_BUFSIZE		2000
 
 struct emac_eth_dev {
 	struct emac_regs *regs;
@@ -455,7 +455,7 @@ static int _sunxi_emac_eth_recv(struct emac_eth_dev *priv, void *packet)
 
 	/* Move data from EMAC */
 	if (good_packet) {
-		if (rx_len > DMA_CPU_TRRESHOLD) {
+		if (rx_len > EMAC_RX_BUFSIZE) {
 			printf("Received packet is too big (len=%d)\n", rx_len);
 			return -EMSGSIZE;
 		}
-- 
2.3.5



More information about the U-Boot mailing list