[U-Boot] [PATCH 00/24] usb: s3c-otg: Rename driver to dwc2-otg

Marek Vasut marex at denx.de
Fri Dec 4 03:37:58 CET 2015


The driver is for the dwc2 otg block , so rename it accordingly finally.

Marek Vasut (24):
  usb: s3c-otg: Rename regs-otg.h to s3c_udc_otg_regs.h
  usb: s3c-otg: Rename struct s3c_udc to dwc2_udc
  usb: s3c-otg: Rename struct s3c_usbotg_reg to dwc2_usbotg_reg
  usb: s3c-otg: Split private bits from s3c_udc.h
  usb: s3c-otg: Rename struct s3c_usbotg_phy to dwc2_usbotg_phy
  usb: s3c-otg: Rename struct s3c_dev_*_ep
  usb: s3c-otg: Rename struct s3c_ep
  usb: s3c-otg: Rename struct s3c_request
  usb: s3c-otg: Staticize s3c_udc_ep_set_stall
  usb: s3c-otg: Staticize functions in s3c_udc_otg_xfer_dma.c
  usb: s3c-otg: Rename s3c_ep0_*() functions
  usb: s3c-otg: Rename s3c_ep_*() functions
  usb: s3c-otg: Rename s3c_udc_*() functions
  usb: s3c-otg: Rename remaining local s3c_*() functions
  usb: s3c-otg: Zap useless externs
  usb: s3c-otg: Change the driver name to dwc2-udc
  usb: s3c-otg: Rename local headers to dwc2_*h
  usb: s3c-otg: Rename sources to dwc2_*c
  usb: s3c-otg: Rename remaining macros
  usb: s3c-otg: Tweak the comments
  usb: s3c-otg: Rename USB_GADGET_S3C_UDC_OTG* to USB_GADGET_DWC2_OTG*
  usb: s3c-otg: Rename struct s3c_plat_otg_data
  usb: s3c-otg: Rename s3c_udc_probe() function
  usb: s3c-otg: Rename usb/s3c_udc.h to usb/dwc2_udc.h

 board/altera/arria5-socdk/socfpga.c                |   6 +-
 board/altera/cyclone5-socdk/socfpga.c              |   6 +-
 board/broadcom/bcm28155_ap/bcm28155_ap.c           |   8 +-
 board/denx/mcvevk/socfpga.c                        |   6 +-
 board/ebv/socrates/socfpga.c                       |   6 +-
 board/samsung/goni/goni.c                          |   6 +-
 board/samsung/odroid/odroid.c                      |   6 +-
 board/samsung/trats/trats.c                        |   8 +-
 board/samsung/trats2/trats2.c                      |   6 +-
 board/samsung/universal_c210/universal.c           |   6 +-
 board/terasic/sockit/socfpga.c                     |   6 +-
 drivers/usb/gadget/Makefile                        |   4 +-
 drivers/usb/gadget/bcm_udc_otg_phy.c               |   6 +-
 .../usb/gadget/{s3c_udc_otg.c => dwc2_udc_otg.c}   | 205 +++++++++++----------
 .../{s3c_udc_otg_phy.c => dwc2_udc_otg_phy.c}      |  21 ++-
 .../usb/gadget/dwc2_udc_otg_priv.h                 |  43 ++---
 .../usb/gadget/{regs-otg.h => dwc2_udc_otg_regs.h} |  32 ++--
 ..._udc_otg_xfer_dma.c => dwc2_udc_otg_xfer_dma.c} | 202 ++++++++++----------
 include/configs/bcm28155_ap.h                      |   2 +-
 include/configs/exynos4-common.h                   |   4 +-
 include/configs/s5p_goni.h                         |   4 +-
 include/configs/s5pc210_universal.h                |   4 +-
 include/configs/smdkv310.h                         |   4 +-
 include/configs/socfpga_common.h                   |   2 +-
 include/usb/dwc2_udc.h                             |  23 +++
 25 files changed, 319 insertions(+), 307 deletions(-)
 rename drivers/usb/gadget/{s3c_udc_otg.c => dwc2_udc_otg.c} (77%)
 rename drivers/usb/gadget/{s3c_udc_otg_phy.c => dwc2_udc_otg_phy.c} (83%)
 rename include/usb/s3c_udc.h => drivers/usb/gadget/dwc2_udc_otg_priv.h (69%)
 rename drivers/usb/gadget/{regs-otg.h => dwc2_udc_otg_regs.h} (92%)
 rename drivers/usb/gadget/{s3c_udc_otg_xfer_dma.c => dwc2_udc_otg_xfer_dma.c} (88%)
 create mode 100644 include/usb/dwc2_udc.h

-- 
2.1.4



More information about the U-Boot mailing list