[U-Boot] [PATCH] test/overlay: Fix various malloc/free leaks

Langer, Thomas thomas.langer at intel.com
Tue Sep 26 18:28:40 UTC 2017


Hello Tom,

I just read some days ago about the kernel Coding-Style:

<quote>
Choose label names which say what the goto does or why the goto exists.  An
example of a good name could be ``out_free_buffer:`` if the goto frees ``buffer``.
Avoid using GW-BASIC names like ``err1:`` and ``err2:``, as you would have to
renumber them if you ever add or remove exit paths, and they make correctness
difficult to verify anyway.
</quote>

Does is make sense to follow this for U-Boot also and fix the names of the labels below?

> 
>  	free(fdt_overlay_stacked_copy);
> +err3:
>  	free(fdt_overlay_copy);
> +err2:
>  	free(fdt_base_copy);
> +err1:
>  	free(uts);
> 

Best regards,
Thomas



More information about the U-Boot mailing list