[U-Boot] [PATCH 12/15] sandbox: tpm: Tidy up enums and return values

sjg at google.com sjg at google.com
Tue Oct 9 23:51:34 UTC 2018


Use an enum for command values instead of open-coding them. This removes
the need for comments. Also make sure the driver returns proper error
numbers instead of -1.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

 drivers/tpm/tpm_tis_sandbox.c | 20 ++++++++++----------
 include/tpm-v1.h              | 14 ++++++++++++++
 include/tpm-v2.h              |  1 +
 3 files changed, 25 insertions(+), 10 deletions(-)

Applied to u-boot-dm


More information about the U-Boot mailing list