[ELDK] Ubuntu 804 ELDK 4.0 kernel rebuild issues

Detlev Zundel dzu at denx.de
Fri Jul 4 10:01:49 CEST 2008

Hey Dude!

> Detlev,
> Problem solved


> Rebuilt /opt/eldk as user bwr  (v4.0 with rpm fixes from other thread)
> Rebuilding kernel in /opt/linux-2.6.18 as user bwr (as opposed to root)
> /opt is owned by root
> /opt/linux-2.6.18 is owned by bwr
> The problem seemed to be running make as root, not the ownership of
> the directory. I build it in /opt and ~/ and both worked.

Running make as superuser should not pose a problem as such.  You may
have to be carful about a correct environment (PATH, CROSS_COMPILE,
ARCH, ...) when doing so however.

We simply do not normally work as superuser by the very simple
"principle of least privileges" which helps preventing errors to have
severe consequences for the system.  That's also the reason why newer
Linux distros don't even setup a full root account with a password, but
only allow constructs like sudo.


Whenever you find yourself on the side of the majority it is
time to pause and reflect.
                                                -- Mark Twain
DENX Software Engineering GmbH,      MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich,  Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-40 Fax: (+49)-8142-66989-80 Email: dzu at denx.de

More information about the eldk mailing list