[ELDK] Posix Shared Memory

Daniel Stonier d.stonier at gmail.com
Thu May 22 09:31:23 CEST 2008


Using an AMC440EP and just realised the posix shared memory wasn't
around. Had somewhat taken that for granted on my pc systems. To
configure the kernel I've tried

Filesystems -> Pseudo filesystems -> Virtual memory filesystem support

or more simply, tmpfs. Do I also need to enable

General Setup -> Use full shmem filesystem?

Regardless, neither seem to be working. If I use the tmpfs and mount
it on /dev/shm as the man pages suggest, the tmpfs seems to work.
Creation of files there work ok and disappear on unmounting, but still
I get errors when trying to create a shared memory object. The
returned error value (errno) obtained after a failed shm_open is also
curious - 38. Which is one of the real time signals, not an expected
shm_open error value.

If anyone's tried this before and has some advice, it'd be much
appreciated, thanks.
Daniel Stonier.

More information about the eldk mailing list