[ELDK] Unable to compile latest U-boot with ELDK 5.4

Peter Germer germerp at gmail.com
Wed Jan 8 08:52:26 CET 2014

Dear Wolfgang,

2014/1/7 Wolfgang Denk <wd at denx.de>:
> Dear Peter,
> In message <CAMJBY6ZRUd4hA-+c1m0=orxUGhbUkw1L8ArJtyyFb+kpJMk3+w at mail.gmail.com> you wrote:
>> Dear List,
>> Recently I tried to compile latest U-boot from git repository, with no success.
>> After installing ELDK 5.4 from ISO provided on Denx FTP server, I
> ...
>> When I try to compile U-boot, I got the following error:
> ...
>> arm-linux-gnueabi-ld.bfd: unrecognized option '-Wl,-O1'
>> arm-linux-gnueabi-ld.bfd: use the --help option for usage information
>> make[1]: *** [built-in.o] Error 1
> This is a known (and documented) problem.
>> Do you have any idea what could cause these errors, and if there is a
>> way to compile U-boot with the provided ELDK?
> Please see the FAQ entry here:
> http://www.denx.de/wiki/view/ELDK-5/FrequentlyAskedQuestionsAndAnswers#Compiling_U_Boot_or_Linux_fails

Indeed, it seems I missed that one.
Now I could compile U-boot without any issues, the only problem that
it is still not running on my mini2440. I compiled it with 3 different
versions of CodeBench chains and now with DENX ELDK, but still could
not get it work. But this will be another issue I need to find out.

Thanks for the help!

Best regards,

More information about the eldk mailing list