[ARMboot-users] Re: [U-Boot-Users] [PATCH] update for CSB226
Wolfgang Denk
wd at denx.de
Mon Nov 4 23:35:35 CET 2002
In message <E188n1J-0002qw-00 at hall.mail.mindspring.net> you wrote:
>
> > Any comments about this patch? Should I merge it?
>
> Looks OK to me. This should work for all Xscale.
Thanks, Kyle.
> On a side note Wolfgang. Have you ever considered supporting the
>
> if (machine_is_board_x()) {}
I thought about it once, but not really seriously.
> I know you're busy and this kind of thing is low priority. But it does make
> code, IMHO, more readable and cleaner.
Well, maybe. If you check the #ifdef-mess we have right now, you will
find that
1) many #ifdef's come clustered for seral boards, and I don;t see
much difference between
#if defined(CONFIG_CCM) || \
defined(CONFIG_COGENT) || \
defined(CONFIG_CPCI405) || \
defined(CONFIG_EVB64260) || \
defined(CONFIG_HYMOD) || \
defined(CONFIG_LWMON) || \
defined(CONFIG_PCU_E) || \
defined(CONFIG_W7O) || \
defined(CONFIG_MISC_INIT_R)
/* miscellaneous platform dependent initialisations */
misc_init_r ();
#endif
and
if (machine_is_CCM() || \
machine_is_COGENT() || \
machine_is_CPCI405() || \
machine_is_EVB64260() || \
machine_is_HYMOD() || \
machine_is_LWMON() || \
machine_is_PCU_E() || \
machine_is_W7O() || \
machine_is_MISC_INIT_R() ) {
/* miscellaneous platform dependent initialisations */
misc_init_r ();
}
2) Many of these #ifdef's are used to conditionammy define variables,
or initializers, where an if() cannot be used, so we would have to
support BOTH forms, which is actually worse.
But as I said: I didn't reallys pend much thought on this, so maybe I
overlooked something. Feel free to come up with a more detailed
proposal / patch.
Best regards,
Wolfgang Denk
--
Software Engineering: Embedded and Realtime Systems, Embedded Linux
Phone: (+49)-8142-4596-87 Fax: (+49)-8142-4596-88 Email: wd at denx.de
See us @ electronica 2002 in Munich, Nov 12-15, Hall A3, Booth A3.325
More information about the U-Boot
mailing list