[U-Boot-Users] MPC860T POST

Vuong My-Hong My-Hong.Vuong at au.thalesgroup.com
Tue Jun 24 02:06:00 CEST 2003


Sorry if I didn't make it clear enough.  I'm using version 3.0.4 of gcc.
I downloaded a copy of u-boot-0.3.0 and I'm seeing the same error:

make[1]: Leaving directory `/home/myhong/u-boot-0.3.0/drivers'
make[1]: Entering directory `/home/myhong/u-boot-0.3.0/post'
powerpc-linux-gcc -Wa,-gstabs -D__ASSEMBLY__ -g  -Os  -mrelocatable
-ffixed-r14 -meabi -mrelocatable -ffixed-r14 -meabi -D__KERNEL__
-DTEXT_BASE=0x40000000 -I/home/myhong/u-boot-0.3.0/include -fno-builtin
-DCONFIG_PPC -D__powerpc__ -DCONFIG_8xx -ffixed-r2 -ffixed-r29 -mstring
-mcpu=860 -msoft-float -DCONFIG_PPC -D__powerpc__ -DCONFIG_8xx -ffixed-r2
-ffixed-r29 -mstring -mcpu=860 -msoft-float -c -o cache_8xx.o
powerpc-linux-gcc -g  -Os  -mrelocatable -ffixed-r14 -meabi -mrelocatable
-ffixed-r14 -meabi -D__KERNEL__ -DTEXT_BASE=0x40000000
-I/home/myhong/u-boot-0.3.0/include -fno-builtin -pipe -DCONFIG_PPC
-D__powerpc__ -DCONFIG_8xx -ffixed-r2 -ffixed-r29 -mstring -mcpu=860
-msoft-float -DCONFIG_PPC -D__powerpc__ -DCONFIG_8xx -ffixed-r2 -ffixed-r29
-mstring -mcpu=860 -msoft-float -Wall -Wstrict-prototypes -c -o post.o
{standard input}: Assembler messages:
{standard input}:676: Error: Relocation cannot be done when using
{standard input}:682: Error: Relocation cannot be done when using
{standard input}:688: Error: Relocation cannot be done when using
make[1]: *** [post.o] Error 1
make[1]: Leaving directory `/home/myhong/u-boot-0.3.0/post'
make: *** [subdirs] Error 1
myhong at nemo ~/u-boot-0.3.0 $powerpc-linux-gcc -dumpversion

Regards, My Hong

Acoustic Mine Imaging
Thales Underwater Systems
274 Victoria Road
Rydalmere NSW 2116
+61 2 9848 3872
+61404 483 823
My-Hong.Vuong at au.thalesgroup.com

>>> Wolfgang Denk 06/23/03 05:25pm >>>
In message <sef6ed4e.055 at gw_tus_syd3.tus.au.thales> you wrote:
> I'm working with an MPC860T on a custom designed board, using
> ppcboot-2.0.0.  I've only recently tried to turn on the POSTs that is

PPCBoot is dead. Please use U-Boot instead.

> offered with ppcboot/uboot and have tried to 
>    CFG_POST_MEMORY     | \
>     CFG_POST_CPU   | \
>    CFG_POST_CACHE  | \
>    CFG_POST_UART  | \
>    )
> However, on compilation, I get the following:
> {standard input}: Assembler messages:
> {standard input}:513: Error: Relocation cannot be done when using
> -mrelocatable
> {standard input}:519: Error: Relocation cannot be done when using
> -mrelocatable
> {standard input}:525: Error: Relocation cannot be done when using
> -mrelocatable

You have omitted the interesting part: the command line  causing  the
error.  It  seems  to  me  you are not using the correct command line

> Any ideas?  should I be able to compile this with version 3.0.4?  If
> so, how can I get this to work?

Version 3.0.4 of what?

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at denx.de 
Another Armenia, Belgium ... the weak innocents who always seem to be
located on a natural invasion route.
 -- Kirk, "Errand of Mercy", stardate 3198.4

This SF.Net email is sponsored by: INetU
Attention Web Developers & Consultants: Become An INetU Hosting Partner.
Refer Dedicated Servers. We Manage Them. You Get 10% Monthly Commission!
INetU Dedicated Managed Hosting http://www.inetu.net/partner/index.php 
U-Boot-Users mailing list
U-Boot-Users at lists.sourceforge.net 

More information about the U-Boot mailing list