[U-Boot-Users] U-Boot hang

Leon KUKOVEC leon.kukovec at ultra.si
Wed Oct 29 16:35:04 CET 2003

Hi everybody,

I'm in the process of writting PCMCIA support for WEPEP250 (boards/wepep250).
Everything seems to be going smooth except one thing:

When I add a debug function and then execute U-Boot command "pinit on" or
"ide reset" U-boot hangs on me. I sometimes get "data abort",
sometimes "invalid instruction" and sometimes nothing.

Is there any limits with regards to U-Boot's size and by me putting too much
inside U-boot's .text section and hitting some marker/border ?

The situation:
	ident_cpy() function used in ide_ident() copies firmware, version,
	ident string from iop structure to dev_desc structure. Since
	CompactFlash firmware string and model number string are in big endian
	byte order I wanted to write ident_swap_cpy, but as I wrote the
	function, re-compiled U-boot, downloaded it and issued "ide reset" I
	got a hang.
	I also tried to put just two printf's inside ident_copy() -
	a hang again.

ident_swap_cpy() worked fine when I compiled and ran it in my examples/ide.c



Best Regards,

More information about the U-Boot mailing list