[U-Boot-Users] Cascaded U-Boot setup question

Mike Wellington wellington at lucent.com
Tue Apr 13 18:22:11 CEST 2004

Now I tried:

 > tftp 0x200000 u-boot.bin ;  go 0x200100

U-boot begins execution but hangs after the DRAM message.

Mike Wellington wrote:
> Hi-
>   I have multiple Xilinx ML300 boards.  Each one has its own
> ip address.  Each board may have different boot parameters - baud
> rate, root file system, etc.  Basically each board needs its
> own boot parameters stored in some kind of non-volatile storage.
> But there is no working non-volatile storage on these boards (yet),
> until I get I2C EEPROM working.  Each board just boots from its
> copy of u-boot (which is generic) from the microdrive.  Now, I
> could sit at each board and as it comes up, stop the autoboot
> and manually enter the parameters, but that's clunky.  What
> I want to do is build a board-specific u-boot with parameters
> that are specific to that machine-name.   So my boot
> process would be:
> 1)  Load the generic u-boot off the microdrive.  It knows what
>  *machine-name*  is and where to get the next stage at.
> 2)  Use the generic u-boot to download a machine-specific u-boot,
>     uboot-<machine-name>, which I can recompile and change at will
>     since it resides on my tftp server.  I don't have to rewrite
>     the microdrive every time I want to change the boot parameters,
>     all I have to do is build a new *second-stage* machine-specific
>     u-boot-<machine-name> and put it in the /tftp download directory.
> 3)  Run the 2nd u-boot (u-boot-<machine-name>)
>   (which has the machine specific parameters)
>     and let it boot the kernel with the arguments that I want.
> I tried downloading an uncompressed u-boot and loading it at 0x20000,
> then just saying "go 0x20000" and it doesn't work, it generates and
> illegal instruction exception.  (is the starting address of u-boot not
> at the beginning of the .TEXT section - I'll go check after I send this
> email)
> I tried downloading a compressed u-boot with '-T standalone' and then
> saying "bootm 0x200000"  and that doesn't work either.
> Is this doable? It should be.  Does anybody know how to do it?
> I guess the other thing I "could" do is run expect on the serial port
> and set up the paramters that way, but I think the *cascaded u-boot*
> idea is better.
> -mike wellington
>  wellington at lucent.com
>  platforms at bithead.com
> -------------------------------------------------------
> This SF.Net email is sponsored by: IBM Linux Tutorials
> Free Linux tutorial presented by Daniel Robbins, President and CEO of
> GenToo technologies. Learn everything from fundamentals to system
> administration.http://ads.osdn.com/?ad_id=1470&alloc_id=3638&op=click
> _______________________________________________
> U-Boot-Users mailing list
> U-Boot-Users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/u-boot-users

More information about the U-Boot mailing list