[U-Boot-Users] Re: Reading or writing jffs2 - how?

Martin Egholm Nielsen martin at egholm-nielsen.dk
Mon Dec 20 15:09:51 CET 2004

Hi Detlev,

>>I have tried to create a jffs2-image of the linux-filesystem I wish to
>>use, and then write it to my flash using "nand write.jffs2 100000 0
>>$(filesize)". But with no luck...
>>Then I began to investigate the fundamental "ls" and "nand erase"
>>commands, but neither there did I have any success. Below is a trace
>>of what I've tried in order to get something working.
> Are you really sure, your NAND gets accessed correctly both under
> U-Boot and Linux?  Can you erase / write / readback some data under
> U-Boot by hand?
The problem has been solved...
The reason that "ls" didn't work from u-boot, was that the boards' 
u-boot config-file included an erroneous nand-size:

#define CONFIG_JFFS2_NAND_SIZE 64*1024*1024

My board had only one configuration-file associated, but multiple 
nand-size configurations.

The jffs2-image problems were related to the endianess problems of 


Thanks for all,

More information about the U-Boot mailing list