[U-Boot-Users] C function call in Linux kernel

Frank Young young726 at hotmail.com
Fri Jul 9 00:46:45 CEST 2004


This is probably not a typical u-boot question. Forgive me if you think this 
is not a proper place to post. I just want to find someone who happens to 
have the same experience.

I have installed u-boot 1.0.0 on my walnut board with PPC405. But when I 
tried to load the kernel from monta vista (I am using 3.0 pro), the system 
hangs after "# Transferring control to Linux (at address 00000000) ...". The 
console output is attached at the end of this email. I checked the kernel 
and found the kernel was started but it was stopped when the early_init() in 
kernel/head_4xx.S is called. early_init() is a c function. So I guess there 
must be something wrong with the memory configuration thus it affects the 
stack setup. Does anyone have any clue what is happening here?

BTW, since I am using kernel 2.4.18, I don't think I have to set 
clocks_in_mhz. I tried it though, it doesn't work.


=> bootm
## Booting image at 00400000 ...
   Image Name:   Linux-2.4.18_mvl30-walnut
   Image Type:   PowerPC Linux Kernel Image (gzip compressed)
   Data Size:    631784 Bytes = 617 kB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
## Current stack ends at 0x01FBBB98 => set upper limit to 0x00800000
## cmdline at 0x007FFF00 ... 0x007FFF48
bd address  = 0x01FBBF84
memstart    = 0x00000000
memsize     = 0x02000000
flashstart  = 0xFF800000
flashsize   = 0x00400000
flashoffset = 0x00000000
sramstart   = 0x00000000
sramsize    = 0x00000000
bootflags   = 0x0000A000
procfreq    =    200 MHz
plb_busfreq =    100 MHz
pci_busfreq =     25 MHz
ethaddr     = 00:00:48:B9:00:52
IP addr     =
baudrate    =   9600 bps
No initrd
# Transferring control to Linux (at address 00000000) ...

Express yourself instantly with MSN Messenger! Download today - it's FREE! 

More information about the U-Boot mailing list