[U-Boot-Users] A question about sdram_init

Frank Young young726 at hotmail.com
Fri May 14 02:22:27 CEST 2004

>Frank, frankly: you must learn to give us some  more  information  if
>you expect useful replies.

OK, the system I am using is PPC405 custom board. The board is same as 
WALNUT but install a special purpose I/F in ASIC. That's why I said it is 
similiar as WALNUT. Since that part won't interfere others, it can be 
considered same as WALNUT. The board has 8M bytes SDRAM installed. SDRAM 
address space is 0x0-0x7FFFFFFF. Flast ROM address space is 0xFFC00000 - 

> > > > 1. The sdram() hanged after 2nd line, i.e. after set up 4MB. But it
> > >didn't
> > > > go through 3rd line and didn't return.
>For example, until now you didn't bother to tell us which source file
>you are talking about. or what are the characteristics of your board.
>"similiar as WALNUT"? This doesn't mean anything.

Sorry, wrong function name. I've corrected in the second post. The problem 
happens in cpu/ppc4xx/sdram.c -> sdram_init().

> > I don't have a debugger. But I do have LEDs on the board, so I simply 
>Get a debugger, so you can  singlestep,  check  register  and  memory
>contents, etc.

I know. But my boss keep saying learnning to use the debugger is 
time-consuming and refused to buy a debugger for me, which really pissed me 
off. Sigh... But this is the reality - I don't have a debugger and have to 
have to have the u-boot run on my system within one week...

> > >How do you know your code is correct?
> >
> > I didn't write any code. All these three lines were in original
> > sdram_init(). Original sdram_init() tried to detect sdram with different
>Which source file  are  you  talking  about?  cpu/ppc4xx/sdram.c?  or
>cpu/ppc4xx/spd_sdram.c? or what?


> > BTW, I commented out udelay(200). But I don't think it will have any 
>Why did you do that? RAM chips may have a power  on  delay.  Did  you
>read the RAM manufacturer's users manual?

Well, my purpose is just to find out why the 3rd instructions can not get 
through. So I just strip everything which is temporary is not related to 
this purpose. Do you think udelay can be a cause? I really doubt it because 
I've tried both occasions but none of them works.



Is your PC infected? Get a FREE online computer virus scan from McAfee® 
Security. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963

More information about the U-Boot mailing list