[U-Boot-Users] CPM on 8250 board seems stuck.

Subodh Nijsure SNijsure at SkyStream.com
Sun May 16 01:23:23 CEST 2004


I have a PPC8250 based on which I am trying to boot u-boot. First I am
using 8260 toolchain to compile this image, as 8250 is supposed to be
of 8260. 

I have configured SCC1 to be the console port.

When I step through the code using BDI, I see is the code is stuck in a
loop in serial_putc waiting for the Buffer descriptor ready bit to get
in putc function.

       while ( tbdf->cbd_sc & BD_SC_READY )

According to the hardware configuration the CPM should be running at 200 Mhz
and core at 300 Mhz.
I have CPM factor of 3, , Core Factor 4.5 

Now when I reset the SCM by writing to the reset regiser, CPM is supposed to
clear the bit when reset is done and I see that CPM is resetting itself

However I am bit stumped as to why the buffer descriptor may not be getting
cleared. I have checked the external signal CTS, the Tx should be happening.
I have
tried all the baud rates. Only thing I have not tried is auto-baud.

So yesterday I changed order of init and tried to initialize the I2C first 
and right after the I2C init tried to perform a read
something from a address I know where a I2C device is located, I don't see
any activity lines on those pins there either.

It appears to me that CPM is "dead". Now how do I prove things either way,
that it is not dead or its is working. Any CLUES I would really appreciate

In case someone does want to take at my config file I have attached it.

Anybody here that has done 8250 board, and booted u-boot on it, care to
share your 
config.h file?

-Subodh Nijsure

-------------- next part --------------
A non-text attachment was scrubbed...
Name: test8250.h
Type: application/octet-stream
Size: 15847 bytes
Desc: not available
Url : http://lists.denx.de/pipermail/u-boot/attachments/20040515/a90343ba/attachment.obj 

More information about the U-Boot mailing list