[U-Boot-Users] cfi_flash is now working with 64 bit port width

Wolfgang Denk wd at denx.de
Sat Jul 2 00:53:27 CEST 2005

In message <00a301c57e57$4bf8ac90$0606010a at aselsan.com.tr> you wrote:
> When I run the first line, It worked for a few minutes and produced an srec 
> file of about 2 gigabytes length. (It might be bigger but stopped with an 
> out of space error.) (ppc_82xx-objcopy --gap-fill=0xff -O srec u-boot 
> u-boot.srec)

The binutils have some serious problems; it is not too  difficult  to
send them into infinite loops crerating infinite output images.

> But I think, as Wolfgang mentioned, the problem is that; I ignored or
> frankly speaking didn't recognized -msoft-float option given to gcc.
> since -msoft-float is used, floating point instructions are not compiled as
> expected by gcc. (an example "%f" in printf is printed onto console as
> exactly "%f" :-) )

Now this has a much simpler reason: we don;t support FP in U-Boot  at
all,  so  it  is missing completely from the printf() implementation,
too. This has nothing to do with the -msoft-float flag being used  or

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
Brain: an apparatus with which we think we think.    - Ambrose Bierce

More information about the U-Boot mailing list