AW: [U-Boot-Users] USB booting...

Peter Korsgaard jacmet at
Tue Jul 12 18:39:32 CEST 2005

>>>>> "Martin" == Martin Krause <Martin.Krause at> writes:

 Martin> I tried this with a read-only ext2 root file system on a
 Martin> linux partition on an USB memory stick some time ago - and
 Martin> failed. I hadn't much time to analyze what's going wrong but
 Martin> I think the problem was that the kernel (linuxppc_2_4_devel
 Martin> from denx) tried to mount the root file system _before_
 Martin> initializing of the usb sub system has completed. At least
 Martin> the console messages looked so - but perhaps I missed
 Martin> something.

 Martin> Has anybody else tried this? I would be happy to hear about a
 Martin> successful way to do this.

Yes, there's a race condition between the kernel mounting the rootfs
and USB detection / partition scan - I have solved it with a small
initrd (~100k) which sits in a loop trying to mount the USB stick and
then does a pivot_root to it.

Bye, Peter Korsgaard

More information about the U-Boot mailing list