[U-Boot-Users] Re: configuring

Simon Poole simon.armlinux at themalago.net
Fri Jul 22 18:00:36 CEST 2005

Dupas.External at infineon.com wrote:
> trying to boot linux2.6.12 with u-boot-1.1.3 on a ARM versatile board I am facing a difficulty .
> the kernel fails at init because i think of my ability to indicate the place where it can find the root file system.
> what is to be put in the bootargs?
> the error message is :
> Root-NFS : no NFS server available.
> please append a correct "root=" boot option
> Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(2,0)
> I have tried many commands all leading to the same error.
> -setenv bootargs "root=/dev/mtdblock0 mem=128M ether=27,0,0xfc800000,0xfc800010,eth0 mtdparts=versatile:0x5c0000 at 0x1c0000(cram
> fs) video=vc:1-2clcdfb:"
> -setenv bootargs "setenv bootargs root=/dev/mtdblock0 mtdparts=armflash.0:0x65d000 at 0x2200000(cramfs) ip=none mem=128 console=ttyAMA0 video=vc:1-2clcdfb:"
> my cramfs is in flash at address 0x341c0000 while the basis of my flash memory is 0x34000000.
> Anyone ?
> greetings 
> thomas

Aaarrgh! The same message on three lists and no-one complains?  Has 
everyone gone soft?

Simon Poole

More information about the U-Boot mailing list