[U-Boot-Users] jffs2 view u-boot/linux

Dave Ellis dge at sixnetio.com
Fri Jun 3 20:54:56 CEST 2005

Jonas Dietsche wrote: 
> > Have you tried using CFG_JFFS2_SORT_FRAGMENTS? I use it and I tried
> > similar test and testfile is deleted for u-boot (for U-Boot 1.1.0).
> > Both jffs2_1pass.c and README.JFFS2 say it is needed if the boot 
> > partition is writable.
> Yes and I had the same behaviour.
> Then I did the following test.
> Defined CFG_JFFS_CUSTOM_PART,  and used
> struct part_info* jffs2_part_info(int part_num)
> {
[ snip - copy NAND to RAM ]
> }> 
> I undefined CONFIG_JFFS2_NAND and did the same tests again.
> And the results are what they should be like. Deleted files are not 
> displayed anymore. If CFG_JFFS2_SORT_FRAGMENTS is disabled they are
> So the NAND functions of jffs2_1pass.c seem not deliver not the values

> they should.
> The comparison of the version -where the inode is set to 0 if it is an

> older version- is never reached and that is why deleted files are
> displayed.
> Have you tested it with NAND or NOR?

I am copying from NAND to RAM and using CFG_JFFS_CUSTOM_PART. I have
tried using the direct NAND functions. They were added after 1.1.0 so I
had to copy to RAM.

I have a 2MiB boot partition that is copied to RAM. It takes too long to
the entire NAND FLASH (one of our products has 128MiB). It is faster to
the kernel from a RAM copy, otherwise the entire kernel is read twice
from NAND,
once for the initial scan and again for the load.

Dave Ellis

More information about the U-Boot mailing list