[U-Boot-Users] RE: No taskfile registers for PCMCIA IDE ?

Václavík Jakub jakub.vaclavik at merz-sw.com
Fri Jun 17 20:21:05 CEST 2005

I using u-boot 1.1.2, configuration derived from Cerfboard and Xsengine.

GPIO pins are configured according to engineering specification for the (Kontron B499 board). For the PCMCIA/IDE stuff I am using these defines: CONFIG_PXA_PCMCIA, CONFIG_PXA_IDE, CONFIG_IDE_8xx_PCCARD, 

CFG_MCMEM0_VAL			0x00004204
CFG_MCATT0_VAL			0x00010504
CFG_MCIO0_VAL			0x00008407
(I tried also different timings IO and common memory.)

CFG_ATA_BASE_ADDR			0x20000000
CFG_ATA_DATA_OFFSET		0x01f0	/* complies with the CIS	*/
CFG_ATA_ALT_OFFSET		0x03f6	/* for the CF card		*/
CFG_ATA_STRIDE			4		/* I tried also 1,2 */

Powering the PCMCIA is like EXADRON1.

The log output is like this:

Reset IDE:
pcmcia_on: programmed mem controller 
No PCMCIA card found!
PCMCIA MEM: 28000000

## Config_base = 0200 ###
## Compare against "TOSHIBA THNCF128MBA"
            Fixed Disk Card
            IDE interface 
            [silicon] [unique] [single] [sleep] [standby] [idle] [low power]
Bus 0: ide_outb (dev= 0, port= 0x208, val= 0xe0) : @ 0x20000208
ide_inb (dev= 0, port= 0x20c) : @ 0x2000020c -> 0xec
** Timeout **

The value read from the "ata status register" is sometimes different for individual builds of the bootloader, but otherwise the value always the same.

The Configuration registers of the CF card are:
Configuration Option register (200H): 0x01
Configuration and Status register (202H): 0x80
Pin Replacement register (204H): 0x2e
Socket and Copy register (206H): 0x00
I tried different INDEXes in Configuration Option register, but the result is still the same.

I can not find out, what I can not access the task file registers. I would appreciate any hint.

Best regards,


-----Original Message-----
From: Grant Likely [mailto:glikely at gmail.com] 
Sent: Friday, June 17, 2005 7:21 PM
To: Václavík Jakub
Cc: u-boot-users at lists.sourceforge.net
Subject: Re: [U-Boot-Users] No taskfile registers for PCMCIA IDE ?

On 6/17/05, Václavík Jakub <jakub.vaclavik at merz-sw.com> wrote:
> Hi all, 
> I am working with PXA255 board (~Cerfboard) and I am trying to access PCMCIA
> CF via IDE. 
> But it goes like this: 
> power PCMCIA - OK 
> get CIS information - OK 
> access CF's Configuration registers - OK 
> access Task File Registers - FAIL: task file registers seem not to be
> present anywhere (!?) 
Please, please, please include output logs when your asking for help. 
Also identify exactly what versions and configuration your using.


More information about the U-Boot mailing list