[U-Boot-Users] NFS booting problem

Terence Soh Terence.Soh at appliedbiosystems.com
Thu Mar 31 08:51:19 CEST 2005


I'm using a FSForth NS9750 developer's kit and I got into some problems 
booting from NFS. My server ip stated in u-boot is but 
when linux is looking up RPC 100003/2 and 100005/1, it's trying ip address Failing to find it, it goes into kernel panic.

Any idea why the server's ip address is changed?? I tried another kit to 
boot from and it worked fine but there are no differences 
in the u-boot environment parameters.

Any hints??

Terence Soh.

My u-boot environment is 
v=oetenv bootargs
bootargs=console=ttyS0 root=/dev/nfs nfsroot= 
Starting kernel ...

done, booting the kernel.
Linux version 2.6.8ABTest (root at darkstar) (gcc version 3.3.3) #6 Thu Mar 
31 14:34:18 SGT 2005
CPU: ARM926EJ-Sid(wb) [41069264] revision 4 (ARMv5TEJ)
CPU: D VIPT write-back cache
CPU: I cache: 8192 bytes, associativity 4, 32 byte lines, 64 sets
CPU: D cache: 4096 bytes, associativity 4, 32 byte lines, 32 sets
Machine: NS9750
Memory policy: ECC disabled, Data cache writeback
NS9750 Rev. 0, running at 398 MHz
On node 0 totalpages: 4096
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 0 pages, LIFO batch:1
  HighMem zone: 0 pages, LIFO batch:1
Built 1 zonelists
Kernel command line: console=ttyS0 root=/dev/nfs 
PID hash table entries: 128 (order 7: 1024 bytes)
Console: colour dummy device 80x30
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Memory: 16MB = 16MB total
Memory: 13620KB available (1941K code, 504K data, 96K init)
Calibrating delay loop... 99.32 BogoMIPS
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
i2c_ns: I2C ns9750 driver $Revision: 1.1 $ initializing
ns9750fb: Using LCD display sharp_lq57
fb0: ns9750fb frame buffer device
NetWinder Floating Point Emulator V0.97 (double precision)
devfs: 2004-01-31 Richard Gooch (rgooch at atnf.csiro.au)
devfs: boot_options: 0x0
JFFS2 version 2.2. (NAND) (C) 2001-2003 Red Hat, Inc.
Console: switching to colour frame buffer device 40x15
Serial: 8250/16550 driver $Revision: 1.2 $ 1 ports, IRQ sharing disabled
ttyS0 at MMIO 0x0 (irq = 30) is a ST16654
Serial: JTAG driver $Revision: 1.2 $
ttyJ0 at MMIO 0x0 (irq = 0) is a JTAGCOMM
RAMDISK driver initialized: 16 RAM disks of 6128K size 1024 blocksize
Ethernet: NS9750 driver $Revision: 1.6 $
Using anticipatory io scheduler
NAND Flash memory mapped to virtual c1851000
NAND device: Manufacturer ID: 0xec, Chip ID: 0x75 (Samsung NAND 32MiB 3,3V 
Scanning device for bad blocks
Using static partition definition
Creating 1 MTD partitions on "a9m9750":
0x00000000-0x02000000 : "(whole)"
ns9750-ohci ns9750-ohci0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
ns9750ts NS9750 touchscreen initialization
24c64: EEPROM driver $Revision: 1.1 $ initializing
NET: Registered protocol family 2
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 1024 bind 2048)
NET: Registered protocol family 1
NET: Registered protocol family 17
ns_eth: PHY (0x13, 0x78e2) = LXT971A detected at 0x1
ns_eth: link mode 100 Mbps full duplex (auto)
IP-Config: Gateway not on directly connected network.
Looking up port of RPC 100003/2 on
RPC: sendmsg returned error 101
portmap: RPC call returned error 101
Root-NFS: Unable to get nfsd port number from server, using default
Looking up port of RPC 100005/1 on
RPC: sendmsg returned error 101
portmap: RPC call returned error 101
Root-NFS: Unable to get mountd port number from server, using default
RPC: sendmsg returned error 101
mount: RPC call returned error 101
Root-NFS: Server returned error -101 while mounting
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(2,0)

More information about the U-Boot mailing list