[U-Boot-Users] Help about tftp download

Jerry Van Baren gerald.vanbaren at smiths-aerospace.com
Wed Nov 2 13:58:32 CET 2005

Li Weichen wrote:
>>Another suggestion: from a (linux) box command line, tftp to your server
>>and verify that it works.  Your message is indicating that your server
>>is and the file you are trying to get is
>>/tftpboot/u-boot.bin so do the following (I'm typing this from memory,
>>so it may not be quite right)...
>>$ tftp
>>tftp> get /tftpboot/u-boot.bin
> Sorry but after I typed tftp, it came up with message looks like
> get uImage froam tftp server automatically.
>>Getting TFTP to work (i.e. properly configured) usually solves the
>>problem in my experience.

Hi Li,

You result description ment nothing to me.  Please cut & paste real 
messages.  Are you typing "tftp" from your _host_ (linux 
server) command line?

OK, I ran a real instance on my home box (Debian 3.1 x86)
vanbaren at dellserver:~$ uname -a
Linux dellserver.lan 2.4.27-050821 #17 SMP Sun Aug 21 22:46:01 EDT 2005 
i686 GNU/Linux

vanbaren at dellserver:~$ dpkg-query -l "*tftp*"
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: 
||/ Name           Version        Description
ii  tftp           0.17-13        Trivial file transfer protocol client
ii  tftpd          0.17-13        Trivial file transfer protocol server

vanbaren at dellserver:~$ ls /tftpboot/hello_world

vanbaren at dellserver:~$ tftp localhost
tftp> get hello_world
Received 101214 bytes in 0.1 seconds
tftp> get /tftpboot/hello_world
Received 101214 bytes in 0.0 seconds
tftp> quit

vanbaren at dellserver:~$ grep tftp /etc/inetd.conf
tftp            dgram   udp     wait    nobody  /usr/sbin/tcpd 
/usr/sbin/in.tftpd /tftpboot

I was a little surprised that the tftp "get" worked with the /tftpboot 
full path.  On a different box that I used (RH), it is configured as "-s 
/tftpboot" for the option (rather than "/tftpboot") so tftpd treats 
paths as relative to /tftpboot and thus the get "/tftpboot/foo" won't 
work because there is no /tftpboot/tftpboot/foo on the server.  This 
should not be your problem since your configuration matches mine.


More information about the U-Boot mailing list