[U-Boot-Users] Issue regarding entry point address

Swapnil Ashok Narkhede S3092131 at student.rmit.edu.au
Fri Sep 16 17:26:59 CEST 2005

Excerpts from previous posts

 > Using the uImage in RAM, when 
 > i try to execute it using bootm from
 > the RAM. i get the following output
 > o/p>>>
 > SWAP$ bootm 0xa0800000
 > ## Booting image at a0800000 ...
 >    Image Name:   Linux Kernel Image
 >    Image Type:   ARM Linux Kernel Image (gzip compressed)
 >    Data Size:    771905 Bytes = 753.8 kB
 >    Load Address: a0800000
>>Download address and load address must differt at by least the  size
>> of the uncompressed kernel size.

The difference between the compressed and uncompressed image is
40 bytes. So i tried to load the image at 0xa0800000 and tried
to give entry point address as 0xa0800040 but then i get
Which means there is not proper image at that address
(or rather, that is not the proper start of the image file).
So how do i look up for the proper load address and entry point
As per the CFG_LOAD_ADDR parameter in /include/configs/pxa255idp.h
load address should be 0xa0800000
but how do i figure out,what is my entry point address.
Please help me resolve this error.

Swapnil Narkhede
Mob:- 0432025023
Email:- s3092131 at student.rmit.edu.au
School of Computer Science and Information Technology
RMIT University, Melbourne

More information about the U-Boot mailing list