[U-Boot-Users] ls of nand jffs2 flash

Charles Krinke ckrinke at istor.com
Sun Dec 17 22:23:27 CET 2006

I got past my malloc troubles this morning. It was the use of the u-boot.lds file from u-boot-1.1.4. Once I accomodated the changes to the linker script, things worked out fine with malloc. It turned out that the av_[] array was linked in as the first item after __u_boot_cmd_start.
Now, on to the next issue. I am trying to setup so I can boot from a jffs2/NAND flash image that has been previously formatted using 'flash_eraseall -j' in linux- 
The flash does mount in u-boot-1.1.6, and I can do both a 'fsinfo' and 'ls' on it. The 'ls' does find the dozen or so files, but it takes about 10 minutes for the 'ls' to complete. I have one partition currently, and it is 16Mbytes.
I could see that when linux copied files to the flash it started at the top (highest address) and worked its way down. When u-boot accesses the flash it starts at the bottom (lowest address) and works its way up. I am wondering if there is a notion of super-block that is not quite compatible between u-boot-1.1.6 and linux-
Can you offer a spot of advice as to why it might take 10 minutes to complete an 'ls' on a formatted jffs2/nand flash?

More information about the U-Boot mailing list