[U-Boot-Users] 1.1.6 at91 based board dataflash copy panic.

Raúl Sánchez Siles rss at barracuda.es
Tue Dec 26 12:53:20 CET 2006

Hello all,

We are trying u-boot 1.1.6 on a customised at91rm9200 board. The main
features are dataflash, 32MB and networking with DM9161.

We have been using u-boot 1.1.4 quite well now, but we would like to test
1.1.6. Kernel boots ok, but we have found a problem.

When we do a cp from the dataflash to ram like this:
cp.b $(kerneladdr) 0x21600000 0x1
where kerneladdr is 0xC0040000

we have the following:

data abort
Resetting CPU ...

and the board hangs, we have to power off and then on.

The funny thing is that if we go through the usual boot procedure, the board
boots linux as expected and then everything works ok.

I would like to debug this situation, so I tried to uncomment the -DDEBUG on
the config.mk file and rebuild u-boot again. Also tried the same adding
some lines like #define #DEBUG_xxx 1 in the board config file, but I was
unable to get more verbose messages.

I would appreciate some help to find the bug or understand what's
happenning. If you need any more information I could provide, just ask.

Thanks and regards.

Raúl Sánchez Siles

More information about the U-Boot mailing list