[U-Boot-Users] Re: transferring control to linux

Josef Angermeier Josef.Angermeier at informatik.stud.uni-erlangen.de
Thu Mar 2 12:51:34 CET 2006

> Hi all,

> we are porting u-boot/linux to a custom board based on mpc8280.
> After having made u-boot-1.1.4 work, we tried booting some 
> test-configured linux 2.6.15 kernels.

> If we start u-boot using Trace32 (lauterbach) all goes well and linux 
> gets loaded, but if we do the same steps disconnecting Trace32, u-boot 
> seems to work properly, but as soon as the control is transferred to 
> linux all seems to be hanged, and the last words visible on the serial are:

> [...]
> ## Loading RAMDisk Image at 00400000 ...
>    Image Name:   Test Ramdisk Image
>    Image Type:   PowerPC Linux RAMDisk Image (gzip compressed)
>    Data Size:    1374924 Bytes =  1.3 MB
>    Load Address: 00000000
>    Entry Point:  00000000
>    Verifying Checksum ... OK
> ## initrd at 0x00400040 ... 0x0054FB0B (len=1374924=0x14FACC)
>    Loading Ramdisk to 07e4e000, end 07f9dacc ... OK
> ## Transferring control to Linux (at address 00000000) ...

> We are wondering if this is an issue involving u-boot or if this is 
> related to linux config (in this case sorry for being off-topic).

Had the same problem. Make sure your board-specific include defines the
correct IMMR-address etc. and the bd_info structure is the same in
u-boot and in linux.

After having checked that you should compile a minimal kernel, check the
logbuffer for output (see DENX FAQ) and debug the kernel. In my case it
hang in some console output function so that i had to fix the serial
debug output the same way i had to fix u-boot before. Then the kernel
just worked great :-)

> Thanks for any help!!

> Ciao,
> Alberto


More information about the U-Boot mailing list