[U-Boot-Users] hello_world.srec compilation error

Jörn Engel joern at wohnheim.fh-wedel.de
Fri Mar 17 14:58:27 CET 2006

On Fri, 17 March 2006 14:39:05 +0100, Mirco Fuchs wrote:
> when trying to compile the u-boot 1.1.4 for an arm target, the following error occured:
> make[1]: *** No rule to make target `hello_world.srec', needed by `all'
> By searching the list i found threads of other people who run into this problem, but i did not found any solutions. Obviously, i'm not alone with this.
> After a few hours of investigation i think i found the reason for this error and i think it could be interresting to some others too.
> I recently updated my debian system, which means, that also all native developement tools including 'make' have been updated. The old version of make was 3.80. With this version it was no problem to compile u-boot. But after the update the make version was 3.81beta. And obviously this version has some problems when interpreting the Makefile.
> I solved this by reinstalling the older make version :-) 

You have solved other problems that way as well.  One annoying effect
was to mess up the dependency handling and recompile the complete
kernel after changing a single .c file.


Simplicity is prerequisite for reliability.
-- Edsger W. Dijkstra

More information about the U-Boot mailing list