[U-Boot-Users] usb storage class CTL timeout problem

Lin Hungwen-RA8614 Winston.Lin at freescale.com
Thu May 18 03:36:42 CEST 2006

 I just tried copying ohci driver, usb.c, cmd_usb.c, and usb_storage.c
files from 1.1.4 to my 1.1.3 source tree but same error msg occurred.
We have maybe 50-50 chance of running into the flash sticks that do not
work with our u-boot;  however, once we jump into linux, the same usb
device is properly recognized.  So, it's likely the linux usb driver is
more forgiving when it comes to usb devices that are not quite usb-spec



Winston Lin
Systems/Applications Developer
Freescale Semiconductor, Inc.
phone: (512) 895-6218
email: winston.lin at freescale.com
-----Original Message-----
From: wd at denx.de [mailto:wd at denx.de] 
Sent: Wednesday, May 17, 2006 5:34 PM
To: Lin Hungwen-RA8614
Cc: u-boot-users at lists.sourceforge.net
Subject: Re: [U-Boot-Users] usb storage class CTL timeout problem 

In message <loom.20060517T001440-141 at post.gmane.org> you wrote:
> Does anyone know why some USB mass storage devices work and some don't

> on the same board with the same u-boot 1.1.3?  I was able to track the

> msg down to

Because some are of poor quality and violate the USB specification?

BTW: did you try using a recent version of U-Boot?

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
"Just think, with VLSI we can have 100 ENIACS on a chip!"
- Alan Perlis

More information about the U-Boot mailing list