[U-Boot-Users] AT91 Kernel oops when loading kernel from dataflash.

Raúl Sánchez Siles rss at barracuda.es
Wed Nov 15 17:08:53 CET 2006

El Lunes, 13 de Noviembre de 2006 11:30, escribió:
> El Jueves, 9 de Noviembre de 2006 08:02, Ulf Samuelsson escribió:
> > Raúl Sánchez Siles wrote:
> > >   Hello all:
> > >
> > >   We're using an AT91RM9200 based board called Portux920T. We have
> > > now a quite stable kernel and u-boot configuration which I attach. We
> > > manage to include a dataflash inside the portux board and get it to
> > > work. At least almost, please read on.
> >
> > >
> > >   We have 64MB Ram and we have tried using 64MB 32bit wide and 32MB
> > > 16bit wide. Flash and Dataflash are both 4MB.
> > >   We will much appreciated whatever info or test that could take out
> > > from this works but... situation. Thank you very much.
> > >
> > >   Regards,
>   Looking at this scheme, one could think that the problem is on the 1st
> stage bootloader. We have tried the binary provided by atmel, several
> others binaries seen on the internet, we have compiled it ourselves using
> u-boot initialisation routines, or without them.

...And indeed it was on the first stage bootloader. There was a problem with 
the SDRAMC Configuration Register. The problem was that the bootloader we 
took were for boards using 16MB of RAM, 16bit wide, while the Portux board 
has 2 32MB chips, 16bit wide each one.

  We modified the 1st bootloader source, so that the SDRAMC_CR programming 
changes the NR (Number of Row bits) from 12 to 13. That was the problem.

  If anyone needs further clarification, just ask.

  Thank you for the advises.


Raúl Sánchez Siles
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.denx.de/pipermail/u-boot/attachments/20061115/590ff1d0/attachment.pgp 

More information about the U-Boot mailing list