[U-Boot-Users] [GIT PULL] [ARM] Please pull from git://denx.de/git/u-boot-arm.git

Wolfgang Denk wd at denx.de
Tue Aug 14 18:09:38 CEST 2007


Dear Peter,

in message <000001c7de84$ee21a460$821ba8c0 at Emea.Arm.com> you wrote:
> 
> Please pull from git://denx.de/git/u-boot-arm.git
> 
> It (actually) contains the following changes from Ulf - next time the commit
> messages 
> will match the CHANGELOG entries......
> 
>   Add MACH_TYPE records for several AT91 boards
>   Merge to two at45.c files into a common file and split to at45.c and spi.c
>   Fix spelling error in DM9161 PHY Support
>   Initialize at91rm9200 board (and set LED)
>   Add PIO control for at91rm9200dk LEDs and Mux.
>   Change dataflash partition boundaries to be compatible with Linux 2.6
> 
>   Signed-off-by:	Peter Pearse <peter.pearse at arm.com>
>   Signed-off-by:	Ulf Samuelsson <ulf at atmel.com>
> 
> Unfortunately I shall not have time to request any more pulls before 17th
> August 2007.

thanks, done.

Here a few comments regarding the code changes:

There were coding style issues in the following files:

        * Trailing white space: board/at91rm9200dk/mux.c, drivers/at45.c,
          drivers/dataflash.c, include/at45.h, include/dataflash.h
        * Trailing empty lines: board/at91rm9200dk/mux.c, cpu/arm920t/at91rm9200/spi.c,
          drivers/at45.c, include/led.h

I cleaned this up already.


The following issues need to be addressed:


include/led.h => seems specific to the at91rm9200dk board only,
                 please move to board directory. Also, the calls to
                 these functions should be handled without #ifdef's
                 in common code. Either use existing functions hooks,
                 or weak references.

drivers/at45.c => has coding style issues - indentation of long,
                  wrapped around lines is broken.

cpu/arm920t/start.S => I'm surprised to see a lot of intialization
                code has now been added to the "reset" entry point.
                Is this by accident, or am I missing something?

include/config_cmd_all.h: "CONFIG_CMD_MUX" is a pretty generic name,
                while here it is used for a board or CPU specific
                feature only. I suggest you rename this into
                something which has a "AT91" in the name, like
                "CONFIG_CMD_AT91_SPIMUX" or so.


Thanks again.

Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
Q: How do you spell "onomatopoeia"?
A: The way it sounds.




More information about the U-Boot mailing list