[U-Boot-Users] FIX: dataflash.c

Håvard Skinnemoen hskinnemoen at gmail.com
Sun Aug 19 23:37:16 CEST 2007


On 8/19/07, Wolfgang Denk <wd at denx.de> wrote:
> In message <20070818231206.GA4040 at gandalf.sssup.it> you wrote:
> > --- drivers/dataflash.c.orig  2007-08-18 17:36:08.000000000 +0200
> > +++ drivers/dataflash.c       2007-08-18 17:37:05.000000000 +0200
> > @@ -27,16 +27,16 @@ AT91S_DATAFLASH_INFO dataflash_info[CFG_
> >  static AT91S_DataFlash DataFlashInst;
> >
> >  #ifdef CONFIG_AT91SAM9260EK
> > -int cs[][CFG_MAX_DATAFLASH_BANKS] = {
> > +int cs[][2] = {
> >       {CFG_DATAFLASH_LOGIC_ADDR_CS0, 0},      /* Logical adress, CS */
> >       {CFG_DATAFLASH_LOGIC_ADDR_CS1, 1}
> >  };
> >  #elif defined(CONFIG_AT91SAM9263EK)
> > -int cs[][CFG_MAX_DATAFLASH_BANKS] = {
> > +int cs[][2] = {
> >       {CFG_DATAFLASH_LOGIC_ADDR_CS0, 0}       /* Logical adress, CS */
> >  };
> >  #else
> > -int cs[][CFG_MAX_DATAFLASH_BANKS] = {
> > +int cs[][2] = {
> >       {CFG_DATAFLASH_LOGIC_ADDR_CS0, 0},      /* Logical adress, CS */
> >       {CFG_DATAFLASH_LOGIC_ADDR_CS3, 3}
> >  };

Why not call it dataflash_cs[] and move it into the board code? It
already pollutes the namespace, is already board-dependent (hence the
#ifdefs) and is apparently buggy?

Then the board code is responsible for defining a
CFG_MAX_DATAFLASH_BANKS symbol which corresponds with the actual
number of entries in the array. Of course, it can still be buggy, but
at least it's contained within the board code.

Haavard

> I hereby reject this patch.
>
> Replacing a configuration option by a hardwired constant which is
> probably wrong on most of the boards is definitely a Bad Thing.
>
> Also, you did not even mention what sort of problem you are trying to
> fix.
>
> Best regards,
>
> Wolfgang Denk
>
> --
> DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
> HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
> Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
> There is an order of things in this universe.
>         -- Apollo, "Who Mourns for Adonais?" stardate 3468.1
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Splunk Inc.
> Still grepping through log files to find problems?  Stop.
> Now Search log events and configuration files using AJAX and a browser.
> Download your FREE copy of Splunk now >>  http://get.splunk.com/
> _______________________________________________
> U-Boot-Users mailing list
> U-Boot-Users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/u-boot-users
>




More information about the U-Boot mailing list