[U-Boot-Users] Interrupt on at91sam9261ek for device keypad

Pranav Desai pranavdes at gmail.com
Fri Dec 28 08:51:49 CET 2007

On 12/19/07, Pranav Desai <pranavdes at gmail.com> wrote:
> Hi,
> I am a newbie on u-boot development and am working on at91sam9261ek
> board. I needed the device keypad(keypad works on pio lines) to work
> with u-boot.  I wrote a driver of sorts for this keypad. But got stuck
> at registering an interrupt for it.
> Although I eventually found a work around by polling the status
> registers and the keypad worked perfectly, I just wanted to know if it
> is possible to do so using interrupt handling ? As searching the list
> I came across many posts which said that u-boot does not support
> interrupt handling.
> If this cannot be done then do I have to do something manually in
> order for interrupt handling to work? Please enlighten me :)
> Thank you
> Pranav

Hi again,

I tried implementing the irq support for at91sam9261ek taking the help
of the list archive.

I configured AIC for interrupt and also the PIO lines. I also tried to
enable interrupt on the arm controller. But I am stuck again, u-boot
hangs at these particular instructions which is used to enable
interrupt on arm

mrs r1, cpsr
bic r1, r1, #0x80
msr cpsr_c, r1    /* It hangs precisely at this instruction */

I am just trying learn about u-boot.
what exactly am I doing wrong? Please help.

More information about the U-Boot mailing list