[U-Boot-Users] U-boot-1.1.4 cache issue on MPIS24KE

sbedara edara sedara2003 at yahoo.co.in
Mon Jan 1 04:02:41 CET 2007

    I have been trying to port u-boot-1.1.4 on to MIPS 24KE processor.
  It runs fine if i run u-boot in  uncache area.
  If i try to run in cache area( before calling relocation() in the board_init_f () ,i change CFG_SDRAM address to 0x80000000 instead of 0xa0000000).
  The u-boot  hangs when it comes to relocation function.
  Please note that i am using the  cache routines in the cpu/mips/cache.S file to initilize/invalidate and lock the cache.
  Could please guide me what could be the problem.
  Can i use the cache routines available in cpu/mips/cache.S to initilize the caches during the boot up process for MIPS24KE?
  Has anybody tried to use the same cache routines to initilize the cache for MIPS24KE processor?.
  Thanks  in advance.

 Send free SMS to your Friends on Mobile from your Yahoo! Messenger. Download Now! http://messenger.yahoo.com/download.php
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.denx.de/pipermail/u-boot/attachments/20070101/0737182b/attachment.htm 

More information about the U-Boot mailing list