[U-Boot-Users] MCF5271 Port.

Zachary P. Landau kapheine at gmail.com
Mon Jan 29 15:54:50 CET 2007

On 1/29/07, Wolfgang Denk <wd at denx.de> wrote:
> In message <371814.45747.qm at web8321.mail.in.yahoo.com> you wrote:
> > I am new to U-Boot. I downloaded u-boot-1.1.6 and plan
> > to use the same on the MCF5271 EVB. My host system has
> > Red Hat 6.
> Sounds as if you have a favour for old code. Be aware  that  problems
> may be lurking in that corner.
> > m68k-elf-gcc: hello_world.o: No such file or directory
> > m68k-elf-gcc: unrecognized option `-MQ'
> > m68k-elf-gcc: stubs.o: No such file or directory
> > m68k-elf-gcc: unrecognized option `-MQ'
> ...
> Seems your toolchain is not working. Try another one.

As Wolfgang says, old toolchains will do this.  When trying to compile a recent
checkout using the 20010318 Snapgear toolchain, I got the same error.  When I
upgraded to the 20060615 release, it worked.

Also note that someone recently had a different problem with compiling the 5271
port using the 20060615 toolchain.  Here's a link to his post and someone's
reply on how to fix it:

I haven't looked at the issue yet.  If you (or anyone) gets a chance, it'd be
helpful to know what the issue is and if this is a real fix or just a

Zachary P. Landau <kapheine at gmail.com>

More information about the U-Boot mailing list