[U-Boot-Users] Aligment problem on ARM target

madcat at takaisin.fi madcat at takaisin.fi
Wed Mar 7 06:12:08 CET 2007


This is not directly related to U-boot, but since it happens in U-boot, 
I'm hoping someone here could help.

I have the U-boot up and running. Now I need to add new network 
protocols to it. They are also working fine except one little detail. 
The 32-bit word aligment is wrong.

The case is exatly the one described here:

Processor is IXP425, Gcc version is 3.3.2, and I've tried to 
enable/disable those traps, but no help. The aligment is still wrong. 

I'm guessing that other place in U-boot that's not a problem since they 
are not using unaligment 32-bit words, but I am since I try to read 
32-bit word from struct and struct isn't aligment correctly. I've tried 
to make it packed, but that didn't help. I got the pointer to that 
struct from U-boot function so there aren't much to do unless I want to 
change whole U-boot.

Has anyone else have similar problem and how did you solve it now that 
it seems that the aligment trap option of the gcc doesn't do anything. 
I've tried to compile new version of gcc, but so far I've only managed 
compiled succesfully binutils.


- Teemu K.

More information about the U-Boot mailing list