[U-Boot-Users] [PATCH] Fix initrd length miscalculation in bootm command

Johns Daniel johns.daniel at gmail.com
Fri Mar 23 23:44:56 CET 2007

On 3/16/07, Timur Tabi <timur at freescale.com> wrote:
> Timur Tabi wrote:
> > Now that I think about it, I guess that statement doesn't make any sense.  I was trying to
> > say that I didn't *break* multi-images.  The patch fixes a problem with initrd + OF.  If
> > you're not using an initrd, then my patch doesn't change anything, so I just wanted to
> > make sure that things that worked before my patch still work after my patch.
> Wolfgang,
> I just wanted to make sure that you understood that this patch does indeed fix a real and
> severe problem with U-Boot, and therefore should be applied.  I submitted this patch over
> a month ago, and it's still not in your repository.  Without this patch, you cannot use an
>   initrd on any ARCH=powerpc kernel.

Just want to confirm that the booting of "arch/powerpc" kernels with
an initrd is currently broken in u-boot 1.2.0. And, that Timur's patch
fixes the issue.

-- Johns

More information about the U-Boot mailing list