[U-Boot-Users] [PATCH 5/7 v3] serial: add s3c64xx serial driver
Jean-Christophe PLAGNIOL-VILLARD
plagnioj at jcrosoft.com
Mon Aug 4 23:19:49 CEST 2008
On 14:45 Mon 04 Aug , Guennadi Liakhovetski wrote:
> Ported from u-boot-1.1.6 driver by Samsung.
>
> Signed-off-by: Guennadi Liakhovetski <lg at denx.de>
> ---
>
> Also added my copyright to the driver.
>
> drivers/serial/Makefile | 1 +
> drivers/serial/s3c64xx.c | 189 ++++++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 190 insertions(+), 0 deletions(-)
> create mode 100644 drivers/serial/s3c64xx.c
>
> diff --git a/drivers/serial/Makefile b/drivers/serial/Makefile
> index c9e797e..2a11ae5 100644
> --- a/drivers/serial/Makefile
> +++ b/drivers/serial/Makefile
> @@ -30,6 +30,7 @@ COBJS-y += mcfuart.o
> COBJS-y += ns9750_serial.o
> COBJS-y += ns16550.o
> COBJS-y += s3c4510b_uart.o
> +COBJS-$(CONFIG_S3C64XX) += s3c64xx.o
> COBJS-y += serial.o
> COBJS-y += serial_max3100.o
> COBJS-y += serial_pl010.o
I've send a patch that break it.
Could you rebase it on the current Wolfgang tree HEAD?
> diff --git a/drivers/serial/s3c64xx.c b/drivers/serial/s3c64xx.c
> new file mode 100644
> index 0000000..9580909
> --- /dev/null
> +++ b/drivers/serial/s3c64xx.c
> @@ -0,0 +1,189 @@
> +/*
> + * (C) Copyright 2002
> + * Gary Jennejohn, DENX Software Engineering, <gj at denx.de>
> + *
> + * (C) Copyright 2008
> + * Guennadi Liakhovetki, DENX Software Engineering, <lg at denx.de>
> + *
> + * This program is free software; you can redistribute it and/or modify
> + * it under the terms of the GNU General Public License as published by
> + * the Free Software Foundation; either version 2 of the License, or
> + * (at your option) any later version.
> + *
> + * This program is distributed in the hope that it will be useful,
> + * but WITHOUT ANY WARRANTY; without even the implied warranty of
> + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> + * GNU General Public License for more details.
> + *
> + * You should have received a copy of the GNU General Public License
> + * along with this program; if not, write to the Free Software
> + * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
> + *
> + */
> +
> +#include <common.h>
> +
> +#include <s3c6400.h>
> +
> +#ifdef CONFIG_SERIAL1
> +#define UART_NR S3C64XX_UART0
> +
> +#elif defined(CONFIG_SERIAL2)
> +#define UART_NR S3C64XX_UART1
> +
> +#elif defined(CONFIG_SERIAL3)
> +#define UART_NR S3C64XX_UART2
> +
> +#else
> +#error "Bad: you didn't configure serial ..."
> +#endif
> +
> +#define barrier() asm volatile("" ::: "memory")
> +
> +/* See table in 31.6.11 */
> +static const int udivslot[] = {
> + 0,
> + 0x0080,
> + 0x0808,
> + 0x0888,
> + 0x2222,
> + 0x4924,
> + 0x4a52,
> + 0x54aa,
> + 0x5555,
> + 0xd555,
> + 0xd5d5,
> + 0xddd5,
> + 0xdddd,
> + 0xdfdd,
> + 0xdfdf,
> + 0xffdf,
> +};
Can we have something more readable?
> +
> +void serial_setbrg(void)
> +{
> + DECLARE_GLOBAL_DATA_PTR;
> + s3c64xx_uart *const uart = s3c64xx_get_base_uart(UART_NR);
> + u32 reg, pclk_ratio = get_PCLK() / gd->baudrate;
why not
u32 reg;
u32 pclk_ratio = get_PCLK() / gd->baudrate;
> + int i;
> +
> + /* PCLK / (16 * baudrate) - 1 */
> + reg = pclk_ratio / 16 - 1;
> + i = pclk_ratio - (reg + 1) * 16;
=>
i = pclk_ratio - (pclk_ratio / 16 - 1 + 1) * 16;
=>
i = pclk_ratio - (pclk_ratio / 16 ) * 16;
=>
i = pclk_ratio - pclk_ratio;
=>
i = 0;
> +
> + uart->UBRDIV = reg;
> + uart->UDIVSLOT = udivslot[i];
base on the cose
uart->UDIVSLOT = udivslot[0];
> +
> + for (i = 0; i < 100; i++)
> + barrier();
> +}
> +
> +#ifdef CONFIG_HWFLOW
> +static int hwflow; /* turned off by default */
why not?
static int hwflow = 0; /* turned off by default */
> +int hwflow_onoff(int on)
> +{
> + switch (on) {
> + case 1:
> + hwflow = 1; /* turn on */
> + break;
> + case -1:
> + hwflow = 0; /* turn off */
> + break;
> + }
> + return hwflow;
> +}
> +#endif
> +
> +#ifdef CONFIG_MODEM_SUPPORT
> +static int be_quiet;
why not?
static int be_quiet = 0;
> +void disable_putc(void)
> +{
> + be_quiet = 1;
> +}
> +
> +void enable_putc(void)
> +{
> + be_quiet = 0;
> +}
> +#endif
> +
Best Regards,
J.
More information about the U-Boot
mailing list