[U-Boot] [RFC][PATCH 00/15] bootm refactoring

Jerry Van Baren gvb.uboot at gmail.com
Wed Aug 13 07:31:27 CEST 2008


Hi Kumar,

I'm on the road this week, so my ability to review code this week is 
suboptimal.  Having said that, this looks good!

Kumar Gala wrote:
> [PATCH 01/15] Update linux bootm to support ePAPR client interface
> [PATCH 02/15] add ability to disable ft_board_setup as part of bootm
> 
> possibly drop this patch if the boots method is acceptable

I don't follow what this remark is saying.

Is there a reason scripting in the "fdt boardsetup" command, eliminating 
the need to call ft_board_setup() as part of the bootm command chain?

> [PATCH 03/15] Clean up usage of icache_disable/dcache_disable
> [PATCH 04/15] fdt: added the ability to set initrd start/end via chosen command
> [PATCH 05/15] fdt: fdt addr w/o any args reports back the current working address
> [PATCH 06/15] bootm: refactor entry point code
> [PATCH 07/15] bootm: refactor ramdisk locating code
> [PATCH 08/15] bootm: refactor fdt locating and relocation code
> [PATCH 09/15] bootm: Set working fdt address as part of the bootm flow
> [PATCH 10/15] bootm: move lmb into the bootm_headers_t structure
> [PATCH 11/15] bootm: refactor image detection and os load steps
> [PATCH 12/15] fdt: refactor fdt resize code
> [PATCH 13/15] fdt: refactor initrd related code
> [PATCH 14/15] fdt: Added resize command
> [PATCH 15/15] boots: start of sub commands
> 
> I believe all the patches except 15/15 should be in a reasonable state
> for u-boot-testing.  I need to add an 'interrupt enable/disable' command
> but with a small hack I'm able to mimic the bootm command on ppc by:
> 
> 	boots start <A> <B> <C>

Per my previous comment: boots is already taken.

> 	boots load_os	/* hacked to disable interrupts */
> 	boots prep_os
> 	boots initrd_relocate
> 	boots fdt_relocate
> 	fdt chosen $initrd_start $initrd_end
> 	fdt boardsetup
> 	boots jump

Would "bootm go" be better than "bootm jump"?  I'm thinking we have a 
"go" command, so "bootm go" sounds better, more symmetric, to me.  Maybe 
I'm painting the bikeshed?

> Right now 15/15 is focused on only PPC w/Linux.  If this looks acceptable
> I'll split 15/15 into proper patches an add support for the other ARCHes
> and OSes.
> 
> - k

Thanks for working this,
gvb



More information about the U-Boot mailing list