[U-Boot] [PATCH v2 1/6] i.MX31: Add NFC_BASE_ADDR definition.
Jean-Christophe PLAGNIOL-VILLARD
plagnioj at jcrosoft.com
Mon Aug 18 23:36:46 CEST 2008
On 11:30 Mon 18 Aug , Magnus Lilja wrote:
> Signed-off-by: Magnus Lilja <lilja.magnus at gmail.com>
> ---
> include/asm-arm/arch-mx31/mx31-regs.h | 11 +++++++++++
> 1 files changed, 11 insertions(+), 0 deletions(-)
>
> diff --git a/include/asm-arm/arch-mx31/mx31-regs.h b/include/asm-arm/arch-mx31/mx31-regs.h
> index b04a718..769c1e8 100644
> --- a/include/asm-arm/arch-mx31/mx31-regs.h
> +++ b/include/asm-arm/arch-mx31/mx31-regs.h
> @@ -168,4 +168,15 @@
> #define CS5_BASE 0xB6000000
> #define PCMCIA_MEM_BASE 0xC0000000
>
> +/*
> + * NAND controller
> + */
> +#define NFC_BASE_ADDR 0xB8000000
> +
> +/*
> + * NFMS bit in RCSR register for pagesize of nandflash
> + */
> +#define NFMS (*((volatile u32 *)CCM_RCSR))
> +#define NFMS_BIT 30
I'll prefer to align it
it's more readable IMHO
Best Regards,
J.
More information about the U-Boot
mailing list