[U-Boot-Users] [PATCH] JFFS2 command support on OneNAND

Fathi Boudra fboudra at gmail.com
Fri Jul 18 16:09:43 CEST 2008


Hi,

> > I really would rather not duplicate all of this, which looks extremely
> > > similar to regular NAND.  Is there reason why we don't use the mtd_info
> > > function pointer interface?
> >
> > Agreed, It's almost same as NAND code.
> > Now nand code uses two modes, legacy and mtd. Because I don't want to
> > break the NAND code , I used the duplicated code.
> > Basically it should be used the common mtd style code except legacy.
> >
> > So first it added the current code, next time it tries to use the
> > common interface and some code clean up.
>

As it is right now, you can't have jffs2 command support on both NAND and
OneNAND.
Dunno if you could have this case (both NAND and OneNAND enabled) but it
will fail to build:
In file included from
/u-boot-1.3.3/include/linux/mtd/onenand.h:21,

                 from
jffs2_1pass.c:279:

/u-boot-1.3.3/include/linux/mtd/bbm.h:49: error: redefinition of 'struct
nand_bbt_descr'
In file included from
jffs2_1pass.c:279:

/u-boot-1.3.3/include/linux/mtd/onenand.h:36: error: redeclaration of
enumerator 'FL_READY'
/u-boot-1.3.3/include/linux/mtd/nand.h:212: error: previous definition of
'FL_READY' was here
/u-boot-1.3.3/include/linux/mtd/onenand.h:37: error: redeclaration of
enumerator 'FL_READING'
/u-boot-1.3.3/include/linux/mtd/nand.h:213: error: previous definition of
'FL_READING' was here
/u-boot-1.3.3/include/linux/mtd/onenand.h:38: error: redeclaration of
enumerator 'FL_WRITING'
/u-boot-1.3.3/include/linux/mtd/nand.h:214: error: previous definition of
'FL_WRITING' was here
/u-boot-1.3.3/include/linux/mtd/onenand.h:39: error: redeclaration of
enumerator 'FL_ERASING'
/u-boot-1.3.3/include/linux/mtd/nand.h:215: error: previous definition of
'FL_ERASING' was here
/u-boot-1.3.3/include/linux/mtd/onenand.h:40: error: redeclaration of
enumerator 'FL_SYNCING'
/u-boot-1.3.3/include/linux/mtd/nand.h:216: error: previous definition of
'FL_SYNCING' was here
jffs2_1pass.c: In function
'put_fl_mem':

jffs2_1pass.c:466: error: redefinition of
'id'

jffs2_1pass.c:459: error: previous definition of 'id' was
here

make[1]: *** [jffs2_1pass.o] Error 1


cheers,

Fathi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.denx.de/pipermail/u-boot/attachments/20080718/5f151deb/attachment.htm 


More information about the U-Boot mailing list