[U-Boot-Users] [PATCH 13/15 v2] ppc4xx: Add Canyonlands NAND booting support

Stefan Roese sr at denx.de
Thu Mar 13 08:19:42 CET 2008


On Thursday 13 March 2008, Jean-Christophe PLAGNIOL-VILLARD wrote:
> On 01:07 Thu 13 Mar     , Wolfgang Denk wrote:
> > In message <20080312230724.GI18968 at game.jcrosoft.org> you wrote:
> > > > +SOBJS	= start.o init.o resetvec.o
> > > > +COBJS	= ddr2_fixed.o nand_boot.o nand_ecc.o ndfc.o
> > >
> > > It will be nice to split one line for each file
> >
> > Why? IMHO the could will not become more readble that way, on
> > contrary...

Right. The readability will suffer a little by changing this into the 
one-object-per-line version.

> When you have mutltiple patch for a makefile, ex : add 2 new file in 2
> patch, it could be applied without rebase it the second patch

Correct. Even though the likelyhood of multiple patches in this specific 
directory is very low. But nevertheless I'm tempted to change it to the 
one-object-per-line version. This makes it also easier to add one object in 
alphabetical order and not having to reorder the lines. Here an example of 
adding "ccccccccccccc.o":

For the multiple-objects-per-line:

-COBJS	= aaaaaaaaaaaa.o bbbbbbbbbbbb.o eeeeeeeeeeee.o
-COBJS	+= ffffffffffff.o hhhhhhhhhhhh.o xxxxxxxxxxxx.o
+COBJS	= aaaaaaaaaaaa.o bbbbbbbbbbbb.o cccccccccccc.0
+COBJS	+= eeeeeeeeeeee.o ffffffffffff.o hhhhhhhhhhhh.o
+COBJS	+= xxxxxxxxxxxx.o

For the one-object-per-line:

COBJS	= aaaaaaaaaaaa.o
COBJS	+= bbbbbbbbbbbb.o
+COBJS	+= cccccccccccc.o
COBJS	+= eeeeeeeeeeee.o
COBJS	+= ffffffffffff.o

Best regards,
Stefan

=====================================================================
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: +49-8142-66989-0 Fax: +49-8142-66989-80  Email: office at denx.de
=====================================================================




More information about the U-Boot mailing list