[U-Boot] [PATCH v5] Marvell MV88E61XX Switch Driver support

Prafulla Wadaskar prafulla at marvell.com
Wed Apr 22 09:11:38 CEST 2009


> > +#include <common.h>
> > +#include <miiphy.h>
> > +#include "mv88e61xx.h"
> > +
> > +/* Chip Address mode
> > + * The Switch support two modes of operation
> > + * 1. single chip mode and
> > + * 2. Multi-chip mode
> > + * Refer section 9.2 &9.3 in chip datasheet-02 for more details
> > + *
> > + * By default single chip mode is configured
> > + * multichip mode operation can be configured in board header  */ 
> > +#ifndef CONFIG_MV88E61XX_MULTICHIP_ADRMODE
> > +#define mv88e61xx_wr_phy miiphy_write #define mv88e61xx_rd_phy 
> > +miiphy_read #else
> > +
> > +static int mv88e61xx_busychk_multic(u32 devaddr) {
> >   
> I mentioned this previously - if you're going to alias 
> functions please do it in a header (I see that you have one now).
This is moved to header file

> > +static void mv88e61xx_vlan_config(struct mv88f61xx_config 
> *swconfig,
> > +				  u32 max_prtnum, u32 ports_ofs)
> >   
> Please rename these functions to make clear that you're 
> configuring port-based VLANs.  Maybe 
> 'mv88e61xx_port_vlan_config()' or something like that.
This is renamed as mv88e61xx_port_vlan_config

> > +
> > +/*
> > + * Marvell 88E61XX Switch initialization  */ int 
> > +mv_switch_88e61xx_init(struct mv88f61xx_config *swconfig)
> >   
> Please add this function's prototype to include/netdev.h
Added also it is renamed as 'mv88f61xx_switch_initialization()'

> > 1.5.3.4
> Thanks for all the hard work.  Address these issues and I'll 
> pull it into the net branch.
I am sending patch v6 for the same, pls kindly pull it

Regards..
Prafulla . .


More information about the U-Boot mailing list