[U-Boot] [PATCH v2] ARM Cortex8 Rename and move v7_flush_dcache_all to flush_dcache

Jean-Christophe PLAGNIOL-VILLARD plagnioj at jcrosoft.com
Sat Aug 8 13:26:11 CEST 2009

On 12:46 Sat 08 Aug     , Dirk Behme wrote:
> Since there is only one version of flushing the dcache for
> arm_cortex8, rename v7_flush_dcache_all to the the generic
> name flush_dcache.  Because the function is intended for
> only omap3 boards, move the function to the new file
> cache_flush.S.
> Signed-off-by: Tom Rix <Tom.Rix at windriver.com>
> Signed-off-by: Dirk Behme <dirk.behme at googlemail.com>
> ---
NACK keep the arm arch version in the name

and as request to Tom remove the non need device_type
and we can safely use the v7 cache flush for omap3 and other cortex a8

Best Regards,

More information about the U-Boot mailing list