[U-Boot] [PATCH 1/3]: arm:kirkwood Define kirkwood phy address magic number
prafulla at marvell.com
Fri Aug 21 05:20:08 CEST 2009
> -----Original Message-----
> From: Simon Kagstrom [mailto:simon.kagstrom at netinsight.net]
> Sent: Thursday, August 20, 2009 5:17 PM
> To: Prafulla Wadaskar
> Cc: U-Boot ML; Ashish Karkare; Prabhanjan Sarnaik
> Subject: Re: [U-Boot] [PATCH 1/3]: arm:kirkwood Define
> kirkwood phy address magic number
> On Thu, 20 Aug 2009 02:40:48 -0700
> Prafulla Wadaskar <prafulla at marvell.com> wrote:
> > >
> > > +#define KIRKWOOD_PHY_ADR_REQUEST 0xee
> > define this in header file
> > Basically this is needed in drivers/net/phy/mv88e61xx.c for
> multi chip support
> > in this case we need to define this in include/miiphy.h.
> > which conflicts with other phy address definition, that's
> why not done earlier
> > It makes more sense to add APIs miiphy_read/write_phyadr to miiutils
> But is this really general functionality? miiphy.h is something I
> suppose should be generic between phys and not contain device-specific
> things like this.
Current PHY support need to be re-architected to support switches in generic ways
This is old pending issue, may be we should re-trigger it again after scheduled release
> Perhaps we should revive the patches that move out the phy
> initialization from sheevaplug.c and place the define and some
> implementation there?
the code can be abstracted from sheevaplug as well as rd6281a for MV88E1116 initialization.
In the beginning I had posted my first patch as separate driver for MV88E1116, but again this is gated due to above rework to be done
Prafulla . .
> // Simon
More information about the U-Boot