[U-Boot] [PATCH 3/3] Consolidate arch-specific mem_malloc_init() implementations

Jean-Christophe PLAGNIOL-VILLARD plagnioj at jcrosoft.com
Sat Aug 22 12:51:46 CEST 2009


On 23:05 Fri 21 Aug     , Peter Tyser wrote:
> Signed-off-by: Peter Tyser <ptyser at xes-inc.com>
> ---
>  common/dlmalloc.c      |   15 +++++++++++++++
>  include/malloc.h       |    2 ++
>  lib_arm/board.c        |   10 ----------
>  lib_avr32/board.c      |   15 ++-------------
>  lib_blackfin/board.c   |    9 ---------
>  lib_m68k/board.c       |   14 +-------------
>  lib_microblaze/board.c |   20 +++++---------------
>  lib_mips/board.c       |   14 +-------------
>  lib_nios/board.c       |   14 ++------------
>  lib_nios2/board.c      |   14 ++------------
>  lib_ppc/board.c        |   14 +-------------
>  lib_sh/board.c         |    9 ---------
>  lib_sparc/board.c      |   21 +--------------------
>  13 files changed, 32 insertions(+), 139 deletions(-)
> 
> diff --git a/common/dlmalloc.c b/common/dlmalloc.c
> index f3bced4..241db8c 100644
> --- a/common/dlmalloc.c
> +++ b/common/dlmalloc.c
> @@ -1520,6 +1520,21 @@ void *sbrk(ptrdiff_t increment)
>  	return (void *)old;
>  }
>  
> +#ifndef CONFIG_X86
could we have a generic name (not arch)
CONFIG_GENERIC_MALLOC_INIT

and then define it in the configs/arch.h
> +/*
> + * x86 boards use a slightly different init sequence thus they implement
> + * their own version of mem_malloc_init()
> + */
> +void mem_malloc_init(ulong start, ulong size)
> +{
> +	mem_malloc_start = start;
> +	mem_malloc_end = start + size;
> +	mem_malloc_brk = start;
> +
> +	memset((void *)mem_malloc_start, 0, size);
> +}
> +#endif
> +
>  /* field-extraction macros */
>  
>  #define first(b) ((b)->fd)
> diff --git a/include/malloc.h b/include/malloc.h
> index 0382169..3e145ad 100644
> --- a/include/malloc.h
> +++ b/include/malloc.h
> @@ -944,6 +944,8 @@ extern ulong mem_malloc_start;
>  extern ulong mem_malloc_end;
>  extern ulong mem_malloc_brk;
>  
Best Regards,
J.


More information about the U-Boot mailing list